Buttons not working

I am using a 3rd party pricing table app integrated on my squarespace site.

I added the url Memberstack gives me to the button link area of the 3rd party app (myurl.com/#/ms/signup/5ebcb57798c7ae0004d693e7). When I click the button it just opens a new page of my website, not the memberstack login.

If I add url to a native squarespace button it works and does what it is meant to (open up a login pop up).

If I add that text to a the elfsight button, it does not work. I have also tried adding it like this: https://www.myurl.com/#/ms/signup/5ebcb57798c7ae0004d693e7

Any ideas on how to get it working?

Hey Jenny :wave:

Welcome, and thank you for posting in the forum! :partying_face:

This is hard to diagnose without seeing it in action. Would you mind sharing a url here or as a private message to me?

Hey Josh! Thanks for replying :slight_smile: This is the URL: https://www.peereducationdentistry.com/

If you scroll down a bit there is a pricing table, thats the elfsight plugin, and the buttons which are not working.

change the buttons for the signup like you have the learn more button below. Using just the #/ms/signup/5ebcb57798c7ae0004d693e7 part

Hey Josh,

Thanks for that suggestion. Just double checked that and it did not work:( The pricing table is a plugin from elfsight, so the buttons are not ‘squarespace’ buttons…do you think that has something to do with it?

https://www.peereducationdentistry.com

Yes I think thats the issue. It looks like the Memberstack code is looking for the links before they are added from elfsight. I do not know if this will work or not but I would try adding the elfsight code above Memberstack.