MemberStack.io

Header Code not recognized and Multi-step form not working

Hi all!

I’m having two issues with my Memberstack form:

  1. memberstack is saying that the header code isn’t installed, but I did exactly what the instructions said. see screenshots:

  2. on my form, when I click to move from step 3 to step 4 of the process, I get a 404 error. Not sure if this is a memberstack issue or a webflow issue. I used this template, and here is the link to the first step in my signup form for reference. I’ve also attached screenshots.

I looked through the forum to see if anyone has asked these questions already, but I didn’t see anything. if these questions have been asked before, I’d appreciate someone sharing the posts!

Hey Toby :wave:

Welcome, and thank you for posting in the forum! :partying_face:

I looked at your signup form. Try adding "data-ms-member=“email” instead of ms-field=“email” on your email field. I also noticed you have some css code that needs editing. This code is under the Memberstack script in your Head Code image above. Try adding style tags to the css like:

<style>
body {
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: greyscale;
}
</style>

Hey Josh - thanks for the response.

So I updated all of the form fields tied to Memberstack with the “data-ms-member” field. I published that update, and I still get taken to that 404 page in the screenshot. Is there something else that could be wrong with the form? It works up until step 3 of my process (enter your company, location, etc.), but it doesn’t take me to step 4 (tell us about your interests).

For the header code, it seems to be working! attached another screenshot just to confirm

Hey Toby :wave:

I just got back from the weekend. Have you added any members yet? If not, try adding a member by hand by clicking on the Create a member button shown in the last screenshot. If it still doesn’t work let me know and I can dive deeper. :smiley:

Hey Josh - so oddly, even though the form still takes me to that 404 page, Memberstack is recognizing new members (see screenshot - I see that you made a test account as well).

The last two pages of the form don’t contain any fields that are tied to Memberstack; step 4 is just additional data that we’d like to gather on our users, and step 5 is just a “Success” message to confirm the membership worked. Does that make a difference? I added the ‘data-ms-form’ and ‘signup’ attributes to the form elements on both of those pages.

im going to private message you :smiley: