Remove Login Bot Protection/Improvements?

Hi there,

We are testing out our sign-in page, and the bot warning keeps on preventing us from logging in and testing. I typed in every single keystroke and it will not get rid of the bot warning.

Using a VPN worked.

Is there a way to remove the bot protection feature?

What can we do to prevent this?

(sorry, lots of questions)
Also, our customer base is mostly of older users over 65, and we want to prevent them from having to struggle just to sign in.

Any tips are greatly appreciated!

Thanks,
Ming

Hey Ming :wave:

Yes you can disable the captcha! :smiley:

Go here and disable the recaptcha slider.

Thank you such a quick reply, Josh!

1 Like

Thanks for posting this @Josh-Lopez. It seems like this was causing an issue with new sign-ups for us on IE11. Unfortunately we still have an audience that is still using IE11 browsers. I turned off the recaptcha and that seems to be the fix.

1 Like

Hi guys! I’m experiencing the same issue with a few customers. Are we sure this is because of the browser being IE11? Is there a way to make sure this doesn’t happen? (just trying to find a suggestion to give them in our FAQ in case they run into this problem).
Thanks!

@Nicolas_Kneler @jmatias — we’ll take a look at this and drop you a note if we can pin-point what might be causing it. :smile:

Hey Naitik! Regarding this issue, is there (or will there be at somepoint) an endpoint for us to get a clue of how often people get this message?

Hey Nicolas! Ah that’s a very cool idea — we haven’t looked a lot into this but I’ll bring this up with the team for our next roadmapping session so we can add it to our list. :slight_smile:

Great! Thanks Naitik!

1 Like

Hi there Josh :wave:

Posting here because even after disabling Recaptcha in the Site Settings, the Recaptcha process is still launching upon log in. It means I can’t login without my VPN on. I am to onboard China-based businesses mainly so this is crucial to me. I’m almost done with the whole design and about to KO.

Is there any way to “force stop” the Recaptacha or bot protection process from ever happening ?

Thanks :pray:,
Yoann.

Hey Yoann :wave:

Welcome, and thank you for posting in the forum! :partying_face:

Turning off the ReCaptcha in the dashboard should disable it. Can you please make a loom.com video of what you are seeing so we can add it as a bug? This would be really helpful. :smiley: Thank you!

Hey Josh,

Thanks for your reply :+1:

Please find the loom recording of the bug below.

Recaptcha bug

As you can see the Recaptcha module first loads but because it is blocked here in China it dies off leaving no option to log in.

Is there any piece of code I can add to the page’s header/body or form hidden embed in order to force disable Recaptcha? Your toggle in the Site Settings supposedly add/remove a piece of code in order to add/remove the function. Could you share the disabling/removing piece of code as a temporary measure so that I can go forward with the kick-off ?

Thanks much in advance,
Yoann.

When you go to your site and look in the console do you see any errors? We don’t see any on our end. We are thinking it may be due to your location. Here is a loom video from our lead developer about this issue. :smiley:

Hi Josh and Tyler,

Thanks a million for looking into my issue with such reactivity :pray:

I’ve done the network test Tyler proposed and everything seems fine (no time-out or 404 on settings) on both VPN actived and deactivated trials (screenshots below - using Chrome).


Tough one :sweat_smile:

Yoann

Hey Yoann :wave:

We are trying to recreate this on our side and we haven’t been able to. Do you maybe have a chrome extension that alters something? Sorry for the shotgun approach, we haven’t seen this happen before.

Hey Josh,

Thanks for your feedback !

My “feeling” is like this isn’t coming from the browser since Recaptcha also kicks in on Safari (both laptop and iPad). I’ve tried clearing my cache, activate/deactivate the Recaptcha in site settings with log out in between each time and no chance either.

I could try and deactivate all of my Chrome extensions to see but I don’t think that it would help given the few I have (see below).

Shall I private message you a test account’s credentials so you can try to connect or you’ve already done that ?

Also, I’ve noticed that the Recaptcha does not kick in during account creation, only at log in. I haven’t linked my Webflow account to any google service up to now but I do use a google font (webfont.js).

There is definitely something in the code that kickstarts the Recaptcha process.

I’ve stop the page load during log in for you to see if there is anything helpful in the queries below.

Thanks again for your help !
Yoann

Hey Yoann :wave:

Could you please provide us with the url you are using and a screenshot of the full error? What is throwing us off is how it says dashboard is coming from Memberstack. We do not have any code that matches that and are unable to replicate the error on our end.

To get a screenshot of the full error, click on the red error and then click on the headers tab.

Thank you! :pray:

Hey Josh,

Sorry for the confusion, I should have given you a bit more of context here. “Dashboard” is coming from MS because this is the page I set up to be the “Page after login”, also called “Dashboard” in Webflow.

There is an error solely because of the fact I am purposely stopping the page load process hoping you could find something in it. That being said, see a full screenshot of the error.

The header for Settings:

When you say you haven’t been able to replicate the bug, do you mean that you could successfully log in onto the dashboard without Recaptcha showing up ?

That is correct. On our end the recaptcha doesnt show up at all. Thank you for these screenshots. I will show them to our dev team. :slight_smile:

Hi Josh,

Thanks for your feedback. I’ve been having multiple people here in China test out the log in and none of them can successfully log in. Recaptcha is timing out blocking the process (some info about it below).

Seems like the Recaptcha request initiator is still Memberstack’s API.

I’ve had people in France test out the log in too and Recaptcha is showing up too by the way (of course that’s not an issue there cause no firewall but it is indeed in the code).

There are a lot of instances of Recaptcha in the Memberstack & Webflow JS, I’ve enclosed them here FYR: https://we.tl/t-MrV2OLBiDY

This tiny bit of an issue is literally wasting the whole effort here. I simply can’t go live and fire the MS subscription…so I really need to keep the ball rolling here.

Digging deeper, I’ve discovered that users in China could use Recaptcha if the target of the script was not “www.google.com” but “www.recaptcha.net” instead. Is there a modification in the code we could bring here ? Source Google.


May be completely unrelated but I’ve seen also that Webflow business’s subs has CDN located in Asia, if it is location sensitive, would it help in solving the issue? We still don’t know what is triggering the Recaptcha and you can’t seem to be able to replicate the issue.

I wish there would be a piece of code that I could paste in the head/body of the page to keep Google off the page/disable the Recaptcha altogether.

I remain available shall you think a direct conversation over zoom would help.

I’ll keep looking !

Thanks,
Yoann.