Update Specific User in CMS

@Matthew_Gavioli hey Matt, are you using Integromat or Zapier for this? And what specifically do you mean by “Webflow ID” - is this a “Member” CMS Item? If so I’ve got exactly the same process running right now and happy to help, just need to understand your flow a bit better.

@JollyGoodWeb Very kind of you. I’m using Integromat. I can pass information from Memberstack to Webflow successfully. The Webflow ID I am referring to is the “Item ID” generated in the Collection when a new item is created.

1:59/2:58 in - I am trying to replicate this exchange in Integromat.

@Matthew_Gavioli I just started listing out my process, then realised I think I misread your question :man_facepalming:t2:

Is it the custom webhook in Integromat that you’re stuck with? If that’s the case then unfortunately I can’t advise as I’ve not tried this yet, as I’m currently using Zapier. Sorry if I got your hopes up, for some reason I read this as you were stuck trying to get the Memberstack / Webflow IDs (tired eyes!)

@Josh-Lopez / @belltyler that video works for me to update a custom field via Integromat (which is awesome, thanks again for that).

However, I also need to update the member page via an HTTP request. I’m attempting to do so via the same method, but can’t get it to work for some reason. I’ve referred to the documentation here, so I’m not sure if it’s simply a syntax error?

Any help massively appreciated. Integromat accepts it but the member page does not update within Memberstack. This is absolutely critical for me to be able to do this via the API.

Ok, now I’m seriously baffled.

I overwrote the working JSON I had (which I used to write the member’s ID to the custom field “Dashboard Slug”), in order to attempt the member page above.

Now, for some reason, whenever I try and implement the working solution I had earlier, Integromat states “502 internal server error” for that step.


EDIT: waited an hour or so and tried again (didn’t change anything) and it worked. After a few more attempts to experiment, including successfully updating the member’s email address via the HTTP request, it’s back to “502 internal server error”. Am I hitting some sort of rate limit?


EDIT2: it’s back to working again, despite me changing nothing. Definitely feels either like a fault (no idea if it would be a fault on Integromat’s or Memberstack’s side though) or some sort of rate limit. I have it back to successfully updating a custom field in the member’s profile within Memberstack, however I still can’t manage to update the Member Page.

I’ve tried using both of the following syntax to no avail - please can someone advise where I’m going wrong? It’s not throwing up any errors within Integromat.

{
   "memberPage" : "URL"
}

and

{
  "memberPage" : {
    "member-page" : "URL"
  }
}

I’ve been attempting this as a separate step in the Integromat scenario, so there is no other JSON within the HTTP request that could be interfering.

I’m stuck on the same thing, did someone resolve this? (can’t write member page field just like Andy Vaughan)

Hey guys!

I looked into the memberPage problem, and found that it’s not updatable at the moment through the API. That said, it’s now been added to the list to add/fix. It should be an easy addition on our end. I’ll keep you all posted here.

@JollyGoodWeb I am going to look into that. You definitely shouldn’t ever get a 502 error while trying to update a member.

2 Likes

Hey @belltyler, appreciate the speedy response, and thanks for looking into it!

The 502 error was particularly weird - it only seemed to happen if I screwed up a few times in a row, then I had to leave it for an hour or so before I could use it again. No idea if that is just coincidental though!

@Cesar_Augusto_Rodrig I have a workaround you can try, if speed is of the essence.

My Integromat flow involves writing a record to Airtable with new members’ details. Zapier is able to update the member page. So I have a simple 1-step zap that triggers when I create a new Member Airtable record - apart from that one zap, the rest of my workflow is via Integromat (much cheaper!).

Let me know if any of that doesn’t make sense (let me know specifically what you are trying to do, and how) and I’ll try and give you more detail later tonight.

@JollyGoodWeb yeh! I just resolved it making a zap that is triggered when a memberstack member is updated and it writes the memberpage field I think you can make that workflow works without the airtable step.

PD: I want to use just Integromat to do this. Using Integromat for some steps and then Zapier to other things seems to be Frankenstein stuff

2 Likes

Hi Tyler,

When trying to update a custom field in Memberstack via a HTTP request, I get a 403 error

  • {“message”:“Missing Authentication Token”}

Is this related? With Integromat it often does not run an error, in some scenarios but the data does not pass across to memberstack. Some fields pull through and others don’t?

I reached out on to the MS Community on Slack also.

Any assitance is appreciated!

Hey Matthew :wave:

Can you provide a little more info, please? A loom.com video may help us understand whats going on better. :smiley:

Thank you for this loom video. It looks like webflow isnt passing the info. Are you ok with getting in a quick zoom call?

1 Like

Hi Josh,

A Zoom call is good for me.

sent you a message with a link to zoom :smiley:

@belltyler Do you know if this add/fix has been completed?

@Matthew_Gavioli yes this has been added :slightly_smiling_face:

1 Like

@belltyler Thank you. I can pass a singular custom field through successfully, although when I add the memberPage field it creates a 400 error. The Memberstack ID is exactly the same as the Slug and I can see the object values passing through in Integromat. Any advice is appreciated.

Hi Guys,

I have been trying to do the same as Matthew and get the same error, is there away of getting this working?

Any advice appreciated.

1 Like

Hey Chris :wave:

Would you mind submitting a bug report? :smiley: