MemberStack.io

Webflow connected MemberStack Profile Form - If the Checkbox Setting called Style is set to Custom, the checkbox field does not display the update. If the Style is set to “Default”, the checkbox displays the update correctly

Hello,

I am hoping someone can assist with this bug, please.

This is in reference to the following tutorial and clone provided by MemberStack / Duncan:

ISSUE: When updating a Member’s profile within a Webflow website via a Form linked to MemberStack, all the fields are updating correctly except the Checkbox fields. If the Checkbox Setting called Style is set to Custom, the checkbox field does not display the update once the page is refreshed. If the Style is set to “Default”, the checkbox displays the update correctly after a page refresh.

  1. I have a website created with Webflow and it has MemberStack connected to it
  2. On the Webflow member page, I have a form which contains the MemberStack Profile fields for the active member and it is connected to MemberStack
  3. This allows the Member to update their profile anytime within the Webflow created website
  4. All fields are updating correctly except the Checkbox fields if the Checkbox Style Setting is set to Custom. If it is set to Default, the update displays correctly.
  5. I am able to see the respective updates in MemberStack when I view the respective Member’s profile
  6. When I refresh the website profile page, the checkbox fields which have the Style set to Custom are no longer selected. Only the checkbox fields which have the Style set to Default appear selected.
  7. This issue appears to be with a setting related to the Checkbox Settings when a checkbox style is set to “Custom”

This issue creates numerous UX issues and the form information is inaccurate.

After a Member updates their profile within the Webflow website, the profile updates correctly within MemberStack but does not display correctly for the user within the Webflow website. As such, the Member sees that the target field becomes unselected after they pressed update so they choose it again and press update. This causes the profile within MemberStack to think the checkbox has now been deselected. When the Member tries again, the field will be changed in MemberStack but will not display in the Webflow website. And the beat goes on….

Can anyone assist with this?

Thank you!

Hey Forfun :wave:

Welcome, and thank you for posting in the forum! :partying_face:

Would you be willing to share a URL to the form you are talking about? We can take a look and try and come up with some custom CSS that could work. We did find this article and would try that first.

I’m having the same issue. Custom styled checkboxes (done within webflow, not custom code) and radio buttons don’t change their status on the profile page. Instead a default looking radio button becomes visible that does show the correct state.

Is there a fix for this, or is it better to custom code the CSS?

thanks for the help out.

Hey Marcel :wave:

Welcome, and thank you for posting in the forum! :partying_face:

Would you mind sharing your custom checkboxes? We want to see if we can provide something to get them working. I created a quick webflow example but I do not know how you are doing your checkboxes specifically. :grinning:

Hi Josh,

Thanks for the help!

This is the page: https://doneatdawn.webflow.io/register-client
You can see the radio buttons at the bottom of the page.

And here is the read only webflow share:
https://preview.webflow.com/preview/doneatdawn?utm_medium=preview_link&utm_source=designer&utm_content=doneatdawn&preview=c4cffb8f6516daa46dc6a37328956e34&pageId=5ee773c8668d3b6b58edc12b&mode=preview

This is all prototype work, that hopefully at some point becomes a reality.

In the profile page it looks like this:
Screen Shot 2020-06-22 at 22.28.05

Hey Marcel, did you find a solution to this?

No, I think there is no solution at this point. The question remains unanswered disappointedly.